Network Outage – Chetwyd Campus
Incident Report for
Northern Lights College
Resolved
This incident has been resolved.
Posted
May
30
,
2025
-
11:29
PDT
Investigating
Hello, everyone!
Please be advised that the network at the Chetwyd campus is currently down. Our team is actively working to resolve the issue as quickly as possible.
We apologize for the inconvenience and appreciate your patience.
Thank you,
Romeo Macabuhay
Posted
May
30
,
2025
-
08:48
PDT
This incident affected: IT Infrastructure and Networks (Internet, Wireless, and Networks).
×
Subscribe to Incident
Subscribe to updates for
Network Outage – Chetwyd Campus
via . You'll receive .