Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 09, 2026 - 12:00 PDT
Scheduled
Hello,
We have scheduled network maintenance at the Fort St. John Campus for this Saturday, May 9, from 12pm to 3pm.
Expected downtime is less than 1 minute. The remaining time within the window is reserved as a buffer for post-implementation troubleshooting, in the unlikely event it's needed.
Please plan accordingly, and reach out if you have any questions or concerns.
Thanks, Romeo Macabuhay
Posted May 04, 2026 - 16:13 PDT
This scheduled maintenance affected: IT Infrastructure and Networks (Internet, Wireless, and Networks, GlobalProtect), Other Services (Print Servers), Academic and Learning Systems (Computer Labs, Audio Visual Systems), Communication and Collaboration (Alertus), and Administrative and Operational (Maintenance Connection).