Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 23, 2025 - 12:00 PDT
Scheduled
Hi everyone,
Just a quick heads-up that we’ll be restarting our internal email server today at 12 noon to perform an emergency maintenance.
What does this mean for you? You may not be able to send or receive emails for about 10–15 minutes during that time. This will affect Outlook on your computer, Outlook Web Access (webmail), and mobile email apps.
Everything should return to normal automatically once the restart is complete. If you notice any issues after 12:30 PM, please don’t hesitate to contact us at helpdesk@nlc.bc.ca.
Thanks for your patience and understanding!
Best regards, Romeo Macabuhay
Posted Apr 23, 2025 - 10:53 PDT
This scheduled maintenance affected: Other Services (Print Servers), IT Infrastructure and Networks (My Apps), and Administrative and Operational (Maintenance Connection).