We’re very sorry for the inconvenience. The mail server has now been fixed. If you did not receive the documents you scanned and emailed by Monday, please re-scan and send them again. They may have been lost when we cleared the system.
Again, we apologize for the trouble. We are working hard to make sure this doesn’t happen again.
Have a great weekend!
Thank you for your understanding, Romeo Macabuhay
Posted Apr 25, 2025 - 18:12 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 25, 2025 - 14:23 PDT
This incident affected: Other Services (Print Servers) and Administrative and Operational (Laserfiche, Maintenance Connection).