Borealis and Informer 5
Incident Report for
Northern Lights College
Resolved
This incident has been resolved.
Posted
Jun
02
,
2025
-
10:01
PDT
Identified
Borealis and Informer 5 are down for maintenance and should be back by 11 a.m. PST. Thanks for your patience.
Posted
Jun
02
,
2025
-
09:57
PDT
This incident affected: Administrative and Operational (Informer, Borealis).
×
Subscribe to Incident
Subscribe to updates for
Borealis and Informer 5
via . You'll receive .