Touchnet Downtime
Incident Report for
Northern Lights College
Resolved
The Colleague Connect for production is now up and running without any issues. Thank you for your patience
Posted
Oct
02
,
2024
-
10:26
PDT
Identified
Touchnet is currently down. We are in contact with Touchnet to resolve the issue as soon as possible.
Posted
Oct
02
,
2024
-
09:07
PDT
This incident affected: Finance and Payment Systems (Touchnet).
×
Subscribe to Incident
Subscribe to updates for
Touchnet Downtime
via . You'll receive .