Chase POS Issue
Incident Report for Northern Lights College
Resolved
All terminals are now operational.
Posted Sep 26, 2024 - 11:11 PDT
Monitoring
The electronic payments have been restored at the following locations:

Dawson Creek Campus:
- Bookstore: Accepting electronic payments.
- Cafeteria: Accepting electronic payments.

Fort St. John Campus:
- Bookstore: Payments now available through Campus Services.
- Cafeteria: Accepting electronic payments.

We're not fully done yet, but we’re much closer to a complete resolution. Stay tuned for further updates.

Update from Karen Mason-Bennet
Posted Sep 25, 2024 - 09:19 PDT
Identified
Chase reported that an outdated SSL (Secure Sockets Layer) certificate is causing unplanned downtime in our Desk/5000 and Move/5000 Ingenico Tetra terminals. We are currently addressing the issue.

More information: https://www.chase.ca/en/support/outage
Posted Sep 24, 2024 - 11:47 PDT
This incident affected: Finance and Payment Systems (Chase).